Yosemite Compatibility

Dear touchAble users, the current touchAble version is not officially compatible with OSX Yosemite, please wait until the next update otherwise use it at your own risk. We will announce some big stuffs in the coming days, stay tuned.

Posted on October 28, 2014 .